Willkommen Gast. Bitte einloggen oder registrieren.

Einloggen mit Benutzername, Passwort und Sitzungslänge
 

Autor Thema: Corrected Version of vWar_1.50r15  (Gelesen 4895 mal)

UTG|SePHTaN

  • Leader
  • Kommodore
  • *
  • Beiträge: 1199
  • Warnlevel: 0
Corrected Version of vWar_1.50r15
« am: 28.10.2010, 21:17:51 »
German:
Jeder der schon versucht hat vWar auf einem aktuellen Server mit PHP>=5.x zu installieren wird eventuell mit dem Problem konfrontiert gewesen sein dass das nicht klappt, oder es zumindestens jede Menge Depreceated Meldungen hagelt.

Ursache ist eine php-Einstellung in der php.ini :
  • short_open_tag=off
    • sicherer aber vWar geht nicht mehr
    • Abhilfe: short_open_tag=on oder gepatches vWar

Die Depreceated-Meldungen gehen nur mit meiner gepatchen Version weg, da ich dort weitestgehend diese durch aktuelle PHP-Konstrukte ersetzt habe :)
English:
Everybody that has yet tried to install vWar on a server with PHP>=5.x might has run into the problem that vWar might not work at all, or getting a lot of depreceated-warnings.

The reason is a setting in the php.ini:
  • short_open_tag=off 
    • off is more secure but vWar doesn't work anymore
    • Workoround: short_open_tag=on or patched version of vWar

The depreceated warnings only disappear with my patched Version of vWar. There i have replaced everything making problems i have found with the newer php-Commands/Syntax.
« Letzte Änderung: 29.10.2010, 02:20:05 von UTG|SePHTaN »

 




Enterprise © Bloc